Disable zooming on Android viewport


#1

Is there a way to disable zooming the viewport on android, maybe with javascript or a custom cordova plugin ?
The meta tag has no effect, it happens with pinch to zoom and input focus.
It actually ruins the whole experience of ionic/web apps…

related bug : https://code.google.com/p/android/issues/detail?id=11912


#2

The meta tag found in the Guide works great for me.
Make sure you have typed it correctly or please post a Codepen with your code.


#3

thanks eugi,
It appears I had text zooming enabled in chrome’s accessibility settings. In this case the view zooms badly… But that’s to be expected I suppose.
Sorry for the noise !


#4

first step be sure to have this at your index meta tags:

<meta name="viewport" content="initial-scale=1, maximum-scale=1, user-scalable=no, width=device-width">

#5

Has this worked ? It doesn’t work for me. I can still zoom in/out in the simulator or device.