DevApp on ionic 4 : issue : no console log

Problem/Bug still existing, very annoying. :roll_eyes:

This definitely needs to be fixed.

Is ionic no longer being developed? I know that sounds like a sarcastic question, but I am sincerely asking. Debugging is one of its core features and it seems to be regressed into oblivion. The lack of console output in “ionic serve” is clearly an ongoing issue. Is this an issue on our end (multiple users), or does the dev team not know this is an issue? If something changed, that has not been communicated down the chain.

When I installed v3 back in the day, everything worked seamlessly. Now I just installed a fresh copy of v4 and nothing works as per the documents (i.e. sample projects, running, debugging, etc.)

Please Ionic Team, can you give us an update on that issue? This is very very very annoying!! How can you develop without the console? How do you people do when you have to test cordova plugins? Do you build every time on the device?? What a waste of time.

DevApp is basically useless for Ionic 4 and reporting this bug in the repository leads only to counterquestion “Why do you need that”. Lifereload cordova android deployment doesnt work either - debugging native-only bugs is a PAIN at the moment. 9apps

Got the same problem.

Try remote debugging.

There’s a good tutorial here which I used to replace doing it via the console log.

https://ionic.zone/debug/remote-debug-your-app#ios

I use Android but with the DevApp, the Chrome DevTools for Remote Debugging do not work.

i know this sucks, i’m new to ionic, and this disappoints me very much. I heard them on a podcast and they’re hard at work on other roadmap things. Be patient. For now I suggest you create a logging service which can temporarily spit out logs to a simple UL list in your UI. Create same API as normal console logs so you can easily switch it back once it’s fixed.

I get partial output, somewhere in my app it stops working, but only in Chrome.

It works fine in Firefox!

Also, if you’re not already familiar with js debugging, read this article…

Can you also tell me what the -c parameter does with ionic serve -c ?

Guys, it is working now!

Get the last version (v 5.0.0) : sudo npm -g install ionic.

Then start your project ionic serve --devapp.

You will see the following output : > ng run app:ionic-cordova-serve --host=0.0.0.0 --port=8100 --cordova-mock --consolelogs --consolelogs-port=53703 Awesome!

Be sure you havethe app installed : https://ionicframework.com/docs/appflow/devapp

More info:



1 Like

Hi, could you help me with this? After running ionic serve --devapp --lab, I’m trying to access the console logs by going into localhost:53703 and even though my Ionic package is up to date, the following message is printed: Upgrade Required.

Has this happened with someone else?

Still got no console log using devapp with Android
With Ionic 5.0.0 updated

log
[ng] i 「wdm」: Compiled successfully.
[ng] [console.log]: “Angular is running in the development mode. Call enableProdMode() to enable the production mode.”
[ng] [console.log]: “calling _sync”
[ng] [console.log]: “OPEN database: _ionicstorage”
[ng] [console.log]: “new transaction is queued, waiting for open operation to finish”
[ng] [console.log]: “OPEN database: _ionicstorage - OK”
[ng] [console.log]: “DB opened: _ionicstorage”
[ng] [console.info]: “[WDS] Live Reloading enabled.”
[ng] [console.log]: “calling _reload”
[ng] [console.log]: “done _reloading”
[ng] [console.log]: “Ionic Native: deviceready event fired after 1897 ms”
[ng] [console.error]: “ERROR” {}
[ng] [console.error]: “ERROR” {}

package.json
“dependencies”: {
@angular/animations”: “^8.1.2”,
@angular/cdk”: “^8.1.1”,
@angular/common”: “^8.1.2”,
@angular/core”: “^8.1.2”,
@angular/forms”: “^8.1.2”,
@angular/http”: “^7.2.2”,
@angular/material”: “^8.1.1”,
@angular/platform-browser”: “^8.1.2”,
@angular/platform-browser-dynamic”: “^8.1.2”,
@angular/router”: “^8.1.2”,
*@ionic-native/core": “^5.0.0”,
@ionic-native/splash-screen”: “^5.0.0”,
@ionic-native/status-bar”: “^5.0.0”,
@ionic/angular”: “^4.7.1”,
@ionic/storage”: “^2.2.0”,
“bootstrap”: “^4.3.1”,
“cordova-android”: “8.0.0”,
“core-js”: “^2.5.4”,
“rxjs”: “~6.5.1”,
“save-dev”: “^2.0.0”,
“tslib”: “^1.9.0”,
“zone.js”: “~0.9.1”
},

And the localhost:53703 got [Upgrade Required]

I got this working after it suddenly stopped by uninstalling DevApp and reinstalling it on my iPhone. I tried many things and that was the only thing that worked for me.