Debug Error "ld: 2 duplicate symbols for architecture arm64"


#1

Hello,

after the last update I have a problem:

ld: 2 duplicate symbols for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

This error comes after i run “ionic cordova run ios” or at xcode in a simulator.

The remove and add of the ios platform doesen´t help :frowning:

Can anyone help me? :frowning:


#2

Remove the console plugin. It is included in the newer cordova-ios versions and not required any more.

Post your ionic info output for verification.


#3

cli packages: (/usr/local/lib/node_modules)

@ionic/cli-utils  : 1.15.2
ionic (Ionic CLI) : 3.15.2

global packages:

cordova (Cordova CLI) : 7.1.0 

local packages:

@ionic/app-scripts : 3.0.1
Cordova Platforms  : ios 4.4.0
Ionic Framework    : ionic-angular 3.7.1

System:

Android SDK Tools : 25.2.5
ios-deploy        : 1.9.2 
ios-sim           : 5.0.13 
Node              : v6.9.4
npm               : 2.15.12 
OS                : macOS Sierra
Xcode             : Xcode 9.0.1 Build version 9A1004 

Environment Variables:

ANDROID_HOME : /Users/renevolbach/Library/Android/sdk/

Misc:

backend : pro

#4

Same problem here.

could you please add a step by step guide how to fix this @Sujan12?

Where do you want us to remove this plugin, from the package.json / config.xml? none of this seems to work. Or do you have to run a build task after this?


#5

If you are on the newest cordova-ios version, 4.5.x, just run ionic cordova plugin rm cordova-plugin-console.
If not, the reason for the problem is a different one. Post more about what exact command you are running and the complete (!) output of the command.


#6

I have the same problem delete cordova-plugin-console but it does not work…Help


#7

after removing ionic cordova plugin rm cordova-plugin-console it’s working fine.