Debbuging android app

Hello guys!
Im having this problem or bug I guess, I am trying to figure this problem for days and im out of options.
Im trying to build and debugg my app on real device. I have already tried through extensions, android studio, etc… but always it ends up on error Task :app:checkDebugAarMetadata FAILED.
Im 100% positive that the routes are aiming right to android-js-engine-release.aar (can send more screenshots to pm). I have also made reinstall of background plugin, deleting Gradle cache, clean build, recompilling dependencies… Any thoughs please?

Assuming you’ve run npx cap sync? How are you trying to build/debug your app? Please share the exact commands you are running.

Are you using npx cap run android?

There are also some troubleshooting items here too - Troubleshooting Android Issues | Capacitor Documentation.

I have tried many commands. Now I am in VScode and trying into terminal in my root app folder “ionic capacitor run android --livereload --external”. Before I did in android folder with Android extension “gradlew clean/build”. “ionic cap build android” in android studio. Everything ends up with this.
Yes now I tried your commands, did not work :frowning:

The last ditch effort is to delete the android folder and re-add it with ionic cap add android if you’ve tried the other items in the link I shared. Obviously, make note of any specific changes you’ve made, for example, to AndroidManifest.xml.

Yes, I thought I’d give it a try and It worked finally! Background runner is also running <3 Well, for first time the error came back but with more info where is the .aar file missing, so I copied it from background runner into android->app->libs(which I had to create) and it works fine now.
Thanks for help man!

1 Like