Could not get agp plugin version

I’ve built my capacitor app, and trying to build the android version I’m getting these errors, and google isn’t being my friend today. Has anyone come across these?

Configure project :app
Error ‘Plugin-Version’ of ‘unspecified’ for ‘com.android.build.gradle.AppPlugin@77632b6c’ is not a valid version number
OneSignal Warning: Could not get AGP plugin version

Configure project :capacitor-cordova-android-plugins
Error ‘Plugin-Version’ of ‘unspecified’ for ‘com.android.build.gradle.LibraryPlugin@1f7803cc’ is not a valid version number
OneSignal Warning: Could not get AGP plugin version