CordovaError: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK

My android sdk is up to date but I’m still gettin this error. Any help?

cordova build android
ANDROID_HOME=C:\Users\Axe\AppData\Local\Android\sdk
JAVA_HOME=C:\Program Files\Java\jdk1.8.0_131
(node:4400) UnhandledPromiseRejectionWarning: CordovaError: Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
Looked here: C:\Users\Axe\AppData\Local\Android\sdk\tools\templates\gradle\wrapper
at Object.module.exports.check_gradle (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\lib\check_reqs.js:90:25)
at GradleBuilder.prepEnv (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\lib\builders\GradleBuilder.js:161:23)
at Api.module.exports.run (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\lib\build.js:152:20)
at C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\Api.js:348:43
at _fulfilled (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\node_modules\q\q.js:834:54)
at self.promiseDispatch.done (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\node_modules\q\q.js:863:30)
at Promise.promise.promiseDispatch (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\node_modules\q\q.js:796:13)
at C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\node_modules\q\q.js:604:44
at runSingle (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\node_modules\q\q.js:137:13)
at flush (C:\Users\Axe\Desktop\ChatMe\platforms\android\cordova\node_modules\q\q.js:125:13)
(node:4400) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function withou
t a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:4400) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will ter
minate the Node.js process with a non-zero exit code.

Never mind solved it:

I had to download Android SDK r25 manually
You can get it from https://dl.google.com/android/repository/tools_r25.2.3-macosx.zip
and copied the template-Folder into my sdk-tools-folder.

node 6.10.3
cordova 7.0.0
tabris 0.4.0

1 Like

Thank you. It worked for me as well