Cordova Overriding Ionic - Application Gets Stuck at "Apache Cordova - Device Ready" Screen


#1

Hi, I was having some issues lately with my Node / NPM / Ionic installations, so removed everything and installed again.

Since then, I notice a weird behavior after I start new projects through Ionic CLI (v1.7.7) - by running ionic start myApp blank, for instance (I’ve already tried removing ios platform and adding again before building the project).

  • Whenever I add the iOS platform, I noticed that the index.html file is not copied to the platforms/ios/www folder
  • When I run the app on iPhone it gets stuck at the “Apache Cordova - Device Ready” screen (probably as a result from the previous);
  • Splash screen shows Cordova logo, instead of Ionic one which used to be shown with my previous installation;
  • Application icon also shows Cordova logo - used to show Ionic logo
    Cordova version is 5.3.3.

I’m running OS X Yosemite and my Node.JS version is 5.0.0.


#2

Hi,
I have the same issue here, even using my existing project.
Also the hooks are not executed.
regards,


#3

Hi,
found the solution. You should downgrade to nodejs 4.2.2

cheers,


#4

Thanks a lot, will try this when I get home. Cheers


#5

And did it worked out when u reached ?