Cordova Ionic Cannot Deploy to emulator An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):

I have a problem with deployment Ionic app into iOS emulator.

After build using the following command:

ionic cordova run ios -l -- --buildFlag="-UseModernBuildSystem=0"

I will get after a successful build and start emulator following cli message:

 [cordova]  ** BUILD SUCCEEDED **
[cordova]  
[cordova]  No target specified for emulator. Deploying to iPhone-X, 12.1 simulator
[cordova]  An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):
[cordova]  Failed to install the requested application
[cordova]  An application bundle was not found at the provided path.
[cordova]  Provide a valid path to the desired application bundle.

With No app installed into the emulator.

I tried to open the generated project in Xcode SDK and after the run in Xcode the app is launched in emulator but stuck on the splash screen with the exception in file main.h on line:

int retVal = UIApplicationMain(argc, argv, nil, @"AppDelegate");

I tried almost everything, update cordova, ionic, ionic scripts, remove and install ios platform but all tries with same result.

I found that before several hours has been released cordova-ios in version 5.0.0

But is not possible to install this version using CLI so I cannot try and verify impact.

So current used version is

<engine name="ios" spec="4.5.5" />

Ionic info result is following:

Ionic:

   ionic (Ionic CLI)  : 4.10.2 (/usr/local/lib/node_modules/ionic)
   Ionic Framework    : ionic-angular 3.9.2
   @ionic/app-scripts : 3.2.2

Cordova:

   cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms     : android 7.1.4, ios 4.5.5
   Cordova Plugins       : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 2.3.2, (and 5 other plugins)

System:

   Android SDK Tools : 26.1.1 (/Users/def/Library/Android/sdk)
   ios-deploy        : 1.9.1
   ios-sim           : 5.0.13
   NodeJS            : v10.6.0 (/usr/local/bin/node)
   npm               : 6.7.0
   OS                : macOS Mojave
   Xcode             : Xcode 10.1 Build version 10B61

I tried everything but without luck.

What should i try to run app in emulator or device?

Thanks for any advice.

Origin topic can be found here: