Compatible node/npm versions


I lately updated homebrew and now my build is breaking.

When I do “ionic cordova build ios” the build is stopping at “lint finished” and I am getting no error.
(Please see attachment below).
Therefore I am thinking the issue was caused by the update.

My versions:
Ionic: 3.20.0
Cordova: 7.1.0
Node: v8.12.0
npm: 6.4.1

Which version do I need to change to make it work again?

Would mean a lot if someone could help me because I found nothing on the internet regarding this problem.
Thanks in advance. (Sorry for the bad English)

[11:37:02]  build dev started ... 
[11:37:02]  clean started ... 
[11:37:02]  clean finished in 3 ms 
[11:37:02]  copy started ... 
[11:37:02]  deeplinks started ... 
[11:37:03]  deeplinks finished in 338 ms 
[11:37:03]  transpile started ... 
[11:37:08]  transpile finished in 5.72 s 
[11:37:08]  preprocess started ... 
[11:37:08]  preprocess finished in less than 1 ms 
[11:37:08]  webpack started ... 
[11:37:08]  copy finished in 6.27 s 
[11:37:18]  webpack finished in 9.93 s 
[11:37:18]  sass started ... 
Witout `from` option PostCSS could generate wrong source map or do not find Browserslist config. Set it to CSS file path or to `undefined` to prevent this warning
[11:37:21]  sass finished in 2.43 s 
[11:37:21]  postprocess started ... 
[11:37:21]  postprocess finished in 186 ms 
[11:37:21]  lint started ... 
[11:37:21]  build dev finished in 18.82 s 
> cordova build ios
Building for iPhone XS Max Simulator

Building project: /Users/christianstruckmann/Desktop/OSS/App/OSS/platforms/ios/OSS.xcworkspace

	Configuration: Debug
	Platform: emulator
Build settings from command line:
    CONFIGURATION_BUILD_DIR = /Users/christianstruckmann/Desktop/OSS/App/OSS/platforms/ios/build/emulator
    SDKROOT = iphonesimulator12.0
    SHARED_PRECOMPS_DIR = /Users/christianstruckmann/Desktop/OSS/App/OSS/platforms/ios/build/sharedpch

Build settings from configuration file '/Users/christianstruckmann/Desktop/OSS/App/OSS/platforms/ios/cordova/build-debug.xcconfig':
    CODE_SIGN_IDENTITY = iPhone Developer
    HEADER_SEARCH_PATHS = "$(TARGET_BUILD_DIR)/usr/local/lib/include" "$(OBJROOT)/UninstalledProducts/include" "$(OBJROOT)/UninstalledProducts/$(PLATFORM_NAME)/include" "$(BUILT_PRODUCTS_DIR)"

first of all change your node version to LTS 8.12.0

Thank you for your reply. I just did that. Still not working.

have you find yourapp.xcodeproj in platforms/ios/ folder or not after build stop?

There is no new xcode project file after the build. Thank you for that hint. I tried building the android version and it worked. So it maybe is caused because of the new xcode version 10.0 (and the new iPhones)?

probably it is .see this link

It worked! Thank you so much.

1 Like