Code Push not working, stuck on Splashscreen

Hello guys,
i have the Problem that my CodePush doesnt seems to work.
I tried to get any Error Output with ADB but there is nothing.

What do I have at the moment:

Im using the Production Key not the Staging Key!

  <access origin="" />
  <access origin="" />
  <access origin="" />
  <platform name="android">
    <preference name="CodePushDeploymentKey" value="3kXJ5asdfasdfasdfsG"/>
  <platform name="ios">
    <preference name="CodePushDeploymentKey" value="_X5Zasdfasdfadfasdfasdf"/>


import { CodePush } from 'ionic2-code-push';

  templateUrl: 'app.html',

    this.platform.ready().then(() => { 
      //Code Push
      CodePush.sync(syncStatus, null, downloadProgress);

      function syncStatus(status) {
          switch (status) {
              case SyncStatus.DOWNLOADING_PACKAGE:
              case SyncStatus.INSTALLING_UPDATE:

Yes i have the code-push Plugin installed.
Also every time I upload new Version of my App i increase my Project Version number and be sure that i upload it to the Production channel of Code Push.

Do you face any Problems here?

With Chrome inspect I got the following Error Output:

Opened Issue Ticket on Github:

First of all i saw that i dont have a tslint.json and a typings.json in my Project.
So go ahead and do this if you dont have this files:

npm install 
npm install -g typings
npm install --save @types/angular @types/jquery
typings search lodash
typings install lodash --save
npm install -g tslint
typings install
ionic hooks add
ionic state restore

Could be that some of them arent nessasary but with them in this order it worked for me.
After that you will see a typings.json in your Project. Make sure that it looks like this:

  "dependencies": {
    "lodash": "registry:npm/lodash#4.0.0+20161015015725"
  "devDependencies": {},
  "globalDependencies": {
    "es6-shim": "registry:dt/es6-shim#0.31.2+20160602141504"

After all that i finally got an Error Output:


Seems that the Code Push Plugin wasnt installed correctly.
So i removed it and readded it like this:

cordova plugin rm cordova-plugin-code-push
cordova plugin add cordova-plugin-code-push@latest

So all nessasary Plugins are installed now without any errors.
Also the typings.json got updated
So now we need to try it out:

ionic build android

Note that with the --prod flag you wont get an accurate error output. Just in case something is wrong again.

And VOILA finally it works for me! Long Journey but it wos worth it :smiley: