Changes in project don't builds in Android Studio on MacOS

I ran into a problem - I have a project for reactjs + remix.
I assemble it as needed for Capacitor:

sudo npm run build
sudo npx cap add android
sudo npx cap copy
sudo npx cap sync

then I launch Android Studio and there I launch the project in the emulator (or I assemble the apk, it doesn’t matter). The very first version that I have built is constantly launched. I don’t know what to do anymore.
Any changes that I put in project not shown. Only very first version.
I cleaned cache, I removed project and build it again. No way.
I think that it may be in Android Studio? But where?

Ofcourse when I launch project for web (npm run start) all changes applied.

Try just running npx cap build android. That will build your JS project and run sync.

Also, why are you using sudo? That shouldn’t be needed.

Im sorry but I think I have an idea yet. My app is ReactJS + Remix.
And…as I can see - in fact when I move my web app to capacitor mobile (android for example) its still run all on remix server…
So I have to update all on server also. I thought that all changes that I made will be run locally on mobile…I was wrong.

Hmmm, interesting. I am not a React or Remix user but from my understanding Remix provides a backend to your React app?

If your Capacitor app is pulling from you backend UI elements and such, it is going to be slow and may not get approved in the app store.

Well… is it true?
I dont know it yet. I just start to make an app for stores from my web app.
If so this is not good…

A typical mobile app built with Capacitor should be more like an SPA with an API backend. I think others have tried before with using a backend to serve HTML to their app and the performance just isn’t there like a standard native app.

Maybe someone who has tried can chime in.