Can't install Ionic on MacBook Pro - GitHub permissions error - solved

I’ve been developing with Windows for some time and have bought a Mac for IOS development but I can’t get past the installation process!

I have NOT used sudo anywhere!

I have installed nvm, and also changed folder permissions to get past the permissions problems and now I am getting this error…

% npm install -g ionic/cli

npm ERR! Error while executing:

npm ERR! /usr/bin/git ls-remote -h -t ssh://

npm ERR!

npm ERR! Permission denied (publickey).

npm ERR! fatal: Could not read from remote repository.

npm ERR!

npm ERR! Please make sure you have the correct access rights

npm ERR! and the repository exists.

npm ERR!

npm ERR! exited with error code: 128

I thought Macs were supposed to be easy! :grinning:

Can somebody please tell me what I have done wrong and how to get past this?

Solved BY @ mirkonasato

Nothing to do with Mac or Windows, you’re just trying to install the wrong package. It’s @ionic/cli, not ionic/cli.

1 Like


Thank you so much, it’s been driving me nuts all day!

All good now - I hope!! :grinning: