Can't install google map plugin for iOS - can't clone on npm temp directory

I am trying to install the google maps plugin for Android and iOS, I got the keys for both of them and then I run the command link using cordova to install the plugin.

The Android plugin installs with no problem, but the iOS always give an error of “Permission Denied” the “/Users/francisco/.npm/_cacache/tmp”, when the git command runs it tries to clone the project inside another folder inside this tmp folder, and it has not permission.

Command line:

sudo cordova plugin add cordova-plugin-googlemaps --variable API_KEY_FOR_ANDROID="MY_ANDROID_KEY" --variable API_KEY_FOR_IOS="MY_IOS_KEY" --no-fetch


Plugin "cordova-plugin-googlemaps" already installed on android.
Installing "cordova-plugin-googlemaps" for ios
Failed to install 'cordova-plugin-googlemaps': Error
    at /usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/plugman/fetch.js:205:33
    at _rejected (/usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:864:24)
    at /usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:890:30
    at Promise.when (/usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:1142:31)
    at Promise.promise.promiseDispatch (/usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:808:41)
    at /usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:624:44
    at runSingle (/usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:137:13)
    at flush (/usr/local/lib/node_modules/cordova/node_modules/cordova-fetch/node_modules/q/q.js:125:13)
    at _combinedTickCallback (internal/process/next_tick.js:67:7)
    at process._tickCallback (internal/process/next_tick.js:98:9)
Error: Failed to fetch plugin via registry.
Probably this is either a connection problem, or plugin spec is incorrect.
Check your connection and plugin name/version/URL.
Error: npm: Command failed with exit code 1 Error output:
npm ERR! code 1
npm ERR! Command failed: /usr/bin/git clone --depth=1 -q -b master /Users/francisco/.npm/_cacache/tmp/git-clone-07b14d83
npm ERR! /Users/francisco/.npm/_cacache/tmp/git-clone-07b14d83/.git: Permission denied

That happen even after I run:

sudo chown -R 777 /Users/francisco/.npm/_cacache/tmp

Maybe if I dont use the native one, how can I use the web map as I used on Ionic v1?

I solved my problem following the link above: