Can't get Sqlite plugin to work in my app

I’m using this Sqlite plugin with Capacitor.
I’m running my app on an Android emulator and debug on Chrome devtools.
Any operation I do (e.g. openDatabase()) fails with a Note implemented error.

Am I missing some config?

So I looked at the source code, and can see that the plugin returns the
web version of the lib, hence all the Not implemented.
However, I’m running the app in an Android emulator so I would expect to get the “native” version of the lib. Also, when debugging this code:

const info = await Device.getInfo();
if (info.platform === “ios” || info.platform === “android”) {
this._sqlite = CapacitorSQLite;
} else {
this._sqlite = CapacitorSQLPlugin.CapacitorSQLite;

I have confirmed it evaluates to android, thus I would expect everything to work.

Any ideas/input would be appreciated, as this is a complete blocker for me right now.

Also, if anyone has used any version of Sqlite with Capacitor with success, please let me know.

No one has any experience with said plugin?

Given that it is the recommended plugin according to Ionic themselves, I find it hard to believe that I’m the only person who has used the plugin, or the only one with this problem.

I have the same problem

I gave up on Ionic due to this issue, and the lack of feedback for an “official” plugin.
I’m currently using Quasar instead, hopefully it will work out.

today I tried to download the sample project, and it worked, then, it stopped working, I’m sorry that I have no experience, if I can understand something I’ll write it …

I am trying to build app for Android using the same plugin. I thought I was the only one going crazy. The starter app works. Yes it works.

Using the ‘Device File Explorer’ from Android Studio, I can see that the starter app creates 2 databases without any error. When I try to use the plugin in my app, it doesn’t. Not sure where I am going wrong.

Maybe, contacting the repo owner might help. I’m going to to do that once I’m done posting here.

I raised an issue with the repo owner and he answered it. His answer solved my problem. I can now create the database without any problems. I will test it a few times, but I was missing a few lines of code that needed to be from within Android Studio. Once I added the code and did a build, it worked.

Here’s the link to the answer

@accron, give it a try, if you can. Having a proper database in my mobile app is essential for me. If that is the case with you, try it again.

@miljosh Thanks for investigating.
I later did that change in the .java file and got past the initial problem, but for some reason it still didn’t work at all, but I didn’t get any error of any kind. It failed silently. Unfortunately I have since then deleted my original project so I can’t try it again.

As I mentioned previously, I’m now using Quasar, which is based on Vue, and Vue was/is my preference at this point. I initially asked about the Vue release in this forum, but it’s clear the release is still months away, so I looked for alternatives instead. The Quasar docs really are pro-grade!