Can't build ionic V1 app on ionic cli v4

#1

Here is my ionic info:

[WARN] Bad integration name: gulp

Ionic:

   ionic (Ionic CLI) : 4.12.0 (C:\Program Files\nodejs\node_modules\ionic)
   Ionic Framework   : ionic1 1.3.5
   @ionic/v1-toolkit : 1.0.22

Cordova:

   cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms     : android 7.0.0
   Cordova Plugins       : no whitelisted plugins (15 plugins total)

System:

   NodeJS : v10.15.3 (C:\Program Files\nodejs\node.exe)
   npm    : 6.4.1
   OS     : Windows 10

I am working on a legacy Ionic v1 app with the most recent Ionic CLI and when I run ionic-v1 build it fails. I get these errors:

C:\>ionic-v1 build
[16:09:31] Cannot load gulp: ReferenceError: internalBinding is not defined
[16:09:31] Cannot load gulp: ReferenceError: internalBinding is not defined
[16:09:31] Cannot run sass task: missing in gulpfile.js
[16:09:31] Cannot load gulp: ReferenceError: internalBinding is not defined

This is very strange because when I run gulp build it works fine and I do have a gulp sass function.

  "devDependencies": {
    "@babel/core": "^7.4.0",
    "@babel/preset-env": "^7.4.2",
    "@ionic/v1-toolkit": "^1.0.22",
    "angular-mocks": "1.7.8",
    "bower": "^1.8.8",
    "del": "^4.0.0",
    "fancy-log": "^1.3.3",
    "gulp": "^4.0.0",
    "gulp-angular-templatecache": "^2.2.6",
    "gulp-babel": "8.0.0",
    "gulp-clean-css": "4.0.0",
    "gulp-cli": "2.0.1",
    "gulp-concat": "2.6.1",
    "gulp-if": "2.0.2",
    "gulp-inject": "5.0.2",
    "gulp-jscs": "4.1.0",
    "gulp-jshint": "2.1.0",
    "gulp-load-plugins": "1.5.0",
    "gulp-minify-css": "1.2.4",
    "gulp-ng-annotate": "2.1.0",
    "gulp-print": "5.0.2",
    "gulp-rename": "1.4.0",
    "gulp-sass": "4.0.2",
    "gulp-sourcemaps": "2.6.5",
    "gulp-uglify": "3.0.2",
    "jasmine": "3.3.1",
    "jasmine-core": "3.3.0",
    "jscs": "3.0.7",
    "jshint": "^2.10.2",
    "jshint-stylish": "2.2.1",
    "karma": "4.0.1",
    "karma-chrome-launcher": "2.2.0",
    "karma-coverage": "^1.1.2",
    "karma-jasmine": "2.0.1",
    "karma-remap-istanbul": "0.6.0",
    "main-bower-files": "2.13.1",
    "natives": "^1.1.6",
    "preen": "1.2.0",
    "shelljs": "0.8.3",
    "yargs": "13.2.2"   },