Building error jdk 8 is required

Requirements check failed for JDK 8 (‘1.8.*’)! Detected version: 11.0.8
Check your ANDROID_SDK_ROOT / JAVA_HOME / PATH environment variables.
[ERROR] An error occurred while running subprocess cordova.

    cordova.cmd build android exited with exit code 1.

i did all the environment variables for everything and restrated my pc nothing works