Build proccess changed and now cannot call to api


#1

Something very strange is happening, I am pretty sure its not much to do with ionic but since its ionic project…

I am developing app for our company, and we needed to branch the app at one point and develop two different apps based on the same code.

So I have branched my git repo, and pulled the new branch into new folder. Let me stress, I didn’t change anything whatsoever, exactly same codebase.

In the original folder I run “ionic emulate” to test the app in emulator. That creates ant-build folder in my platforms/android with the apk file “CordovaApp-debug.apk”.

platforms\android\ant-build\CordovaApp-debug.apk

Basically ant is building the app (as far as I understand it which is not much)

Now in the new folder, when I ran “ionic emulate” I got error and couldn’t compile the app. After some poking around it forced me to install some other android-sdk packages. I did install them and since then I am able to compile the app. The only problem is that now the compilation proccess looks completely different (in console) and creates hell of a lot more folders and final apk file is

platforms\android\build\output\apk\android-debug.apk

This wouldn’t bother me so much since I dont really care how my app gets build as long as it does.

BUT the really big problem is that with this new build process for some reason no API calls work. All of them return 404 (whaat?)

Any advice?


#2

Type ionic info and check which Cordova version you have installed. If you have v5.0.0 that now requires a new plugin otherwise all http requests are blocked.


#3

Yeah already found this info on stackoverflow. This really should be written somewhere on top with big red letters…


#4

Thankfully the latest Ionic CLI version 1.4.4 now generates projects that already include the whitelist plugin.