Build Fails on every project, even new ones

Hello, today it seems that i broke something.
When running npm run build it gives an error not by my code

[ ERROR ]  TypeScript: ../../../node_modules/@types/eslint/index.d.ts:451:42
           '"/home/klala/node_modules/@types/estree/index"' has no exported member named 'ChainExpression'. Did you
           mean 'ThisExpression'?

    L450:  CatchClause?: ((node: ESTree.CatchClause & NodeParentExtension) => void) | undefined;
    L451:  ChainExpression?: ((node: ESTree.ChainExpression & NodeParentExtension) => void) | undefined;
    L452:  ClassBody?: ((node: ESTree.ClassBody & NodeParentExtension) => void) | undefined;

[ ERROR ]  TypeScript: ../../../node_modules/@types/eslint/index.d.ts:474:43
           Namespace '"/home/klala/node_modules/@types/estree/index"' has no exported member 'ImportExpression'.

    L473:  ImportDefaultSpecifier?: ((node: ESTree.ImportDefaultSpecifier & NodeParentExtension) => void) | undefined;
    L474:  ImportExpression?: ((node: ESTree.ImportExpression & NodeParentExtension) => void) | undefined;
    L475:  ImportNamespaceSpecifier?: ((node: ESTree.ImportNamespaceSpecifier & NodeParentExtension) => void) | undefined;

[38:07.6]  build failed, watching for changes... in 2.81 s 

before it was working. I have stencil version @stencil/core@2.10.0.
I was trying a lot of stuff today, but the only thing that i installed based on stencil was:

npm install @stencil/core@latest --save-exact

After this i can not build. i could test or create or generate, but not build.

I have npm npm@8.1.1 and node v14.18.0.
Thanks, new here, sorry for not knowing how to express better!!

If you run npm install @stencil/core@2.9.0 does the issue go away?

It seems i broke something else!!!
Cause i tried version 2.9.0 and 2.7.0 and then i tried on the other partition (same user) and the stencil works. To help me i provide the history of commands i typed:

npm run build <- here it was working
 4037  npm install --save ./st-demo 
 4038  npm run serve
 4039  stencil --version
 4040  npm install @stencil/core@latest --save-exact
 4041  npm run build
 4042  npm run serve
 4043  npm install --save-dev @nrwl/react
 4044  npm install --save-dev @nrwl/angular
 4045  npm install -g nx
 4046  nx g @nrwl/react:app st-r-demo
 4047  ng new st-ng-demo
 4048  npm init stencil
 4049  npx create-react-app st-r-demo
 4050  nx g @nrwl/react:app st-r-demo --template typescript
 4051  npx create-react-app st-r-demo --template typescript
 4052  npm init stencil
 4053  cd st-demo <- stencil project
 4054  npm run build
 4055  npm run serve
 4056  npm run build
 4057  npm i
 4058  npm run build <- here it was not working.

Thanks for your time.
Any idea what else could have gone wrong?

It is working now, thanks.
I had broken something, no idea what.
I uninstalled stencil core and reinstalled it and updated all dependencies with npm update --depth=5.
I removed node_modules on home folder too.
Something of those has fixed the issue now.
Glad to see this community, i will come back again to see the issues here for help next time.