Build error in mode prod


#1

I have this error when i compile the apk in --prod mode

Error: Metadata version mismatch for module C:/Users//node_modules/@ionic-native/network/index.d.ts, found version 4, expected 3

But in debug mode works


#2

That’s probably due to the issue discussed over here:


#3

thanks, i’ll ask there


#4

I think it’s just a dependency issue. Could you post your package.json?


#5
  "dependencies": {
    "@angular/common": "4.1.3",
    "@angular/compiler": "4.1.3",
    "@angular/compiler-cli": "4.1.3",
    "@angular/core": "4.1.3",
    "@angular/forms": "4.1.3",
    "@angular/http": "4.1.3",
    "@angular/platform-browser": "4.1.3",
    "@angular/platform-browser-dynamic": "4.1.3",
    "@ionic-native/android-permissions": "^4.2.1",
    "@ionic-native/background-mode": "^4.3.3",
    "@ionic-native/camera": "^4.2.1",
    "@ionic-native/core": "3.12.1",
    "@ionic-native/device": "^4.3.3",
    "@ionic-native/in-app-browser": "^4.1.0",
    "@ionic-native/local-notifications": "^4.2.1",
    "@ionic-native/network": "^4.4.0",
    "@ionic-native/social-sharing": "^4.2.0",
    "@ionic-native/splash-screen": "3.12.1",
    "@ionic-native/status-bar": "3.12.1",
    "@ionic/storage": "^2.0.1",
    "cordova-android": "^6.2.3",
    "cordova-ios": "^4.5.3",
    "cordova-plugin-android-permissions": "^1.0.0",
    "cordova-plugin-background-mode": "~0.7.2",
    "cordova-plugin-camera": "^2.4.1",
    "cordova-plugin-compat": "^1.2.0",
    "cordova-plugin-console": "^1.1.0",
    "cordova-plugin-crosswalk-webview": "^2.3.0",
    "cordova-plugin-device": "^1.1.6",
    "cordova-plugin-inappbrowser": "^1.7.1",
    "cordova-plugin-network-information": "^1.3.4",
    "cordova-plugin-splashscreen": "^4.0.3",
    "cordova-plugin-statusbar": "^2.2.3",
    "cordova-plugin-whitelist": "^1.3.2",
    "cordova-plugin-x-socialsharing": "^5.2.1",
    "cordova-sqlite-storage": "^2.1.1",
    "de.appplant.cordova.plugin.local-notification": "^0.8.5",
    "es6-promise-plugin": "^4.1.0",
    "ionic-angular": "3.5.3",
    "ionic-plugin-keyboard": "^2.2.1",
    "ionic2-auto-complete": "^1.5.2-beta",
    "ionicons": "3.0.0",
    "jquery": "^3.2.1",
    "rxjs": "5.4.0",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.12"

#6

If we create new application and build it it will build seamlessly. but if we try other version its getting an error like gradle not supportive.


#7

Could you just fix all the plugin versions to 4.3.3? Because as the other topic describes, there’s an issue with higher versions beeing incompatible with Angular 5 atm. Also fix the core package to that version. Then remove all your node modules, and run npm install again.


#8

Sorry, that package.json was wrong!!

  "dependencies": {
    "@angular/common": "4.1.2",
    "@angular/compiler": "4.1.2",
    "@angular/compiler-cli": "4.1.2",
    "@angular/core": "4.1.2",
    "@angular/forms": "4.1.2",
    "@angular/http": "4.1.2",
    "@angular/platform-browser": "4.1.2",
    "@angular/platform-browser-dynamic": "4.1.2",
    "@ionic-native/call-number": "^3.12.1",
    "@ionic-native/core": "3.7.0",
    "@ionic-native/email-composer": "^3.10.3",
    "@ionic-native/google-maps": "^3.10.3",
    "@ionic-native/in-app-browser": "^3.14.0",
    "@ionic-native/network": "^4.0.1",
    "@ionic-native/splash-screen": "^3.7.0",
    "@ionic-native/status-bar": "3.7.0",
    "@ionic/storage": "^2.0.1",
    "@types/jquery": "^3.2.13",
    "call-number": "^1.0.1",
    "chart.js": "^2.6.0",
    "cordova-android": "^6.2.3",
    "cordova-custom-config": "^3.3.0",
    "cordova-ios": "^4.4.0",
    "cordova-plugin-console": "^1.0.5",
    "cordova-plugin-device": "^1.1.4",
    "cordova-plugin-email-composer": "git+https://github.com/katzer/cordova-plugin-email-composer.git",
    "cordova-plugin-googlemaps": "^1.4.0",
    "cordova-plugin-googlemaps-sdk": "git+https://github.com/mapsplugin/cordova-plugin-googlemaps-sdk.git",
    "cordova-plugin-inappbrowser": "~1.7.1",
    "cordova-plugin-network-information": "^1.3.3",
    "cordova-plugin-splashscreen": "^4.0.3",
    "cordova-plugin-statusbar": "^2.2.2",
    "cordova-plugin-whitelist": "^1.3.1",
    "cordova-windows": "^5.0.0",
    "ionic-angular": "3.3.0",
    "ionic-plugin-keyboard": "^2.2.1",
    "ionicons": "3.0.0",
    "jquery": "^3.2.1",
    "mx.ferreyra.callnumber": "~0.0.2",
    "rxjs": "5.1.1",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.10",
    "cordova-plugin-themeablebrowser": "^0.2.17"
  },

#9

Okay, same goes for this one. Could you update all ionic-native packages to 4.3.3, remove your node_modules and do an npm install?


#10

Yes of course, i’m on it