Broken images in last blog post


#1

Is it just me or all the images of the last blog post http://ionicframework.com/blog/ionic-creator/ are broken (Not found)?

From the first day I thought they will probably fix it up, but it’s still not. Maybe they didn’t notice or it’s just unavailable from my country? (Spain)

When I try to go “http://ionicframework.com.s3.amazonaws.com/blog/creator/creator-header.png”, for instance, I get a 400 Bad Request and the following XML:

<Error>
	<script id="tinyhippos-injected"/>
	<Code>InvalidArgument</Code>
	<Message>
		Authorization header is invalid -- one and only one ' ' (space) required
	</Message>
	<ArgumentValue>636837d7-ac93-48f9-8677-744305113b8a</ArgumentValue>
	<ArgumentName>Authorization</ArgumentName>
	<RequestId>A94788F4A79B5F45</RequestId>
	<HostId>
		yg7LW0wJoKnQrplOITvTQ8ZQR7WZhMfjQaO1UGtA/uYwwrtE0STZdqjtO/QGZ9+zf/62cfsh5ag=
	</HostId>
</Error>

Hopefully this helps ;o


#2

Works fine for me. =\


#3

Wait… now being in home it also works for me… (Windows 7 + Chrome)
In my work I was using OSX with Chrome… more info tomorrow!


#4

Is it possible the images are being blocked by a anti virus or firewall at your work?


#5

No, I found the problem.

Running in the same machine with safari instead of chrome it worked, so I looked on what was being sent by chrome. Chrome in this machine sends this header (skipping last characters for security):

Authorization: 636837d7-ac93-48f9-8677-************

Probably because I made some kind of auth to another server hosted in amazonaws.com and it gets “cached”?

Going Incognito mode in that chrome also solves the problem. Really looks like some cached auth mess up.

Edit: Yup, absolutely my fault. I have a plugin in Google Chrome called “Modify Headers”, and I set that header in order to debug a REST api I was using. My bad D:

Edit2: I didn’t mean to bump this post, I thought editing it wouldn’t…