Blank screen when the app runs in Android emulator

Hi guys,

I faced a problem as I tried to run my app in an Android emulator. The app starts, I see its splash screen, but after few seconds I’m only able to see a blank white screen. I’ve read a lot about this kind of problem and unfortunately the proposed solutions didn’t help in my case (maybe I’ve missed something).

It is the first time I build an Android app using Capacitor. The same Ionic app works well in an iOS emulator, however, it doesn’t work in the Android emulator I use. The logcat of Android Studio logs every run following five errors:

E/package_name: Invalid ID 0x00000000.
E/package_name: Invalid ID 0x00000000.
E/package_name: Invalid ID 0x00000000.
E/Capacitor: Unable to read file at path public/plugins
E/Capacitor/Browser: Error binding to custom tabs service

I’ve googled for the last two errors, but didn’t find a lot and the proposed solutions didn’t help (like this one).

Here is my capacitor.config.json file content:

  "appId": "*AppId*",
  "appName": "*AppName*",
  "bundledWebRuntime": false,
  "npmClient": "npm",
  "webDir": "www"

I’m using Ionic 6.13.1 along with @capacitor/android 2.4.7 and @ionic/angular 5.6.0.

Last but not least: Because I’m developing on a new Mac with M1 processor I can’t use any of Android emulators proposed in Android Studio. That’s why I’ve downloaded the Android emulator for M1 processors from here.

I would be really thankful for any advice, because I’m running out of ideas :confused:

Best regards

Update here. I’ve generated a new Ionic app based on the tabs template, added capacitor for android and tried to deploy the app in the same Android emulator for M1 processors. No success with the same result and the same errors in logcat. I’m wondering, am I the only one how runs an Ionic app in an Android emulator for M1 processors?

Okay, I’ve figured out, that the downloaded Android emulator from GitHub doesn’t seem to work in a proper way. I’ve downloaded a new image for arm processors directly in Android Studio, created a new AVD and started it in the native emulator. No white screen any more, everything seems to work now.