Blank app fails debug build - /Info.plist file not found

In a larger context I resorted back to creating a blank project and running my build commands.
Same error:

ionic start myApp blank
cd myApp
ionic cordova run ios --debug --target="iPhone-8"  --consolelogs
ionic-app-scripts build --target cordova --platform ios
[11:39:29]  ionic-app-scripts 3.2.0 
[11:39:29]  build dev started ... 
[11:39:30]  clean started ... 
[11:39:30]  clean finished in 1 ms 
[11:39:30]  copy started ... 
[11:39:30]  deeplinks started ... 
[11:39:30]  deeplinks finished in 15 ms 
[11:39:30]  transpile started ... 
[11:39:33]  transpile finished in 3.16 s 
[11:39:33]  preprocess started ... 
[11:39:33]  preprocess finished in 1 ms 
[11:39:33]  webpack started ... 
[11:39:33]  copy finished in 3.31 s 
[11:39:37]  webpack finished in 4.35 s 
[11:39:37]  sass started ... 
[11:39:38]  sass finished in 1.27 s 
[11:39:38]  postprocess started ... 
[11:39:38]  postprocess finished in 10 ms 
[11:39:38]  lint started ... 
[11:39:38]  build dev finished in 8.92 s 
[11:39:41]  lint finished in 2.65 s 
> cordova run ios --debug --target iPhone-8
Building for iPhone 8 Simulator
Building project: /myApp/platforms/ios/myApp.xcworkspace
	Configuration: Debug
	Platform: emulator
Build settings from command line:
    SDKROOT = iphonesimulator12.0

Build settings from configuration file '
    CODE_SIGN_IDENTITY = iPhone Developer
    HEADER_SEARCH_PATHS = "$(TARGET_BUILD_DIR)/usr/local/lib/include" "$(OBJROOT)/UninstalledProducts/include" "$(OBJROOT)/UninstalledProducts/$(PLATFORM_NAME)/include" "$(BUILT_PRODUCTS_DIR)"

/myApp/platforms/ios/build/emulator/ file not found.
[ERROR] An error occurred while running subprocess cordova.
        cordova run ios --debug --target iPhone-8 exited with exit code 1.
        Re-running this command with the --verbose flag may provide more 
ionic --version
cordova --version
8.0.0 & @latest 8.1.1
XCode Version 10.0 (10A255) + build tools
macOS 10.13.6 - High Sierra. Mojave on a different machine fails the same.

-------------- FIX --------------

This is how I got it back up to do livereload without the bugs:

ionic cordova platform remove ios
sudo npm install -g ionic@3.20.0
ionic cordova platform add ios
open platform/ios/MyApp.xcworkspace

Follow instructions to fall back to XCode legacy build system as on

Run my build script as before, without the --buildFlag='-UseModernBuildSystem=0'

Same issue for me on same versions of ionic and cordova

Edit : solved

1 Like

Thanks! However, the flag --buildFlag='-UseModernBuildSystem=0' overrides and disabled livereload or --consolelogs

Seems somebody claims if you fall back to cordova7 it works as before