App is not able to navigate to different pages

I have an android app built via Ionic Framework. The issue is it is working fine in the browser but not working as expected in the android app, which I installed on my phone. The issue is that I am not able to navigate the app on my phone.After connecting to chrome dev tools, seeing the link in the dev tools I found out that there is a difference. The link in dev tools is


and link in my browser is


could this be the reason? Most of you would be doing the same thing. So how do you guys resolve it?

this is the path on your phone… nothing special

So you see some javascript errors in the javascript console of the dev tools?
What happened exactly?

Hi, I see a few errors like cannot find google or and they are just because I haven’t connected them to the app which is hosted at digitalOcean. Only thing I see is that I have a push Notification service and a cordova keyboard plugin which is not working. There is no other error.
Apart from that I created a simple project to emulate the problem. It works fine in my emulated version. It means somewhere I messed up in my code. That is it not rendering the requested page. First guess was that somehow

This is the chrome://inspect window. Could there be a problem because pushNotification and keyboard aren’t working?

yep… so you ran in a hard javascript array and all other javascript is not executed after that.

I didn’t get you on “hard javascript array” . I removed the push notification error and keyboard error. It still persists. So do you mean every error needs to be removed?

It’s solved my app was not able to access the internet. As soon as I downloaded the whitelist plugin. as ran It worked. Thanks so much