Angular Leaflet Directive - Map tile protocol in iOS simulator

I have an Ionic project using the Angular Leaflet Directive (0.10.1) to display a map. When I run this in the browser with ionic serve everything comes up roses and I can see my map and markers, however when I run the project in the iOS simulator with ionic run, the map tiles are not displayed.

Inspecting the webview in Safari shows that it’s attempting to load the map tiles from file:// (ie file:// whereas the browser is correctly trying to load them using the http protocol (ie

Searching this issue came up with a post SO ( The suggested solution was to use v0.7.7. I downgraded to to 0.7.7 and sure enough, the tiles are shown. My markers however, are not, but there are no console errors.

My directive looks like so:
<ion-view view-title="Harbour Map"> <ion-content> <leaflet markers="harbours" height="100%" width="100%" center="center"></leaflet> </ion-content> </ion-view>

With my ‘harbours’ data like so:

      "name":"Imerola Bay",

I’d ideally like to use the most up to date version of the directive but this is not essential.

Has anyone encountered and solved this?

Same issue anybody heeeelppp ((

Same for me, it works perfectly when doing ionic serve or ionic run android -cls, but I can’t manage to get the tiles using ionic run or building. Did you guys solved it ?