Android SDK not found... set the ANDROID_HOME environment variable

This has been asked and answered a ton of times, I have searched around, however none of the solutions seem to apply here.
The was working fine until yesterday, when Android Studio prompted for updates, which I did. Now android builds don’t work, however ANDROID_HOME is set, and it’s correct.

This is on Mac btw.

My ~/.bash_profile

export ANDROID_HOME=/Users/mbeckett/Library/Android/sdk
export PATH=${PATH}:$ANDROID_HOME/tools:$ANDROID_HOME/platform-tools

I can see that ANDROID_HOME is set correctly

Matts-MacBook-Pro-2:wtm mbeckett$ echo $ANDROID_HOME

and that path is correct because it’s listed as the path in Android Studio, and also via command line:

Matts-MacBook-Pro-2:wtm mbeckett$ cd /Users/mbeckett/Library/Android/sdk/
.knownPackages  add-ons/        emulator/       licenses/       platform-tools/ samples/        sources/        temp/
SDK Readme.txt  build-tools/    extras/         patcher/        platforms/      skins/          system-images/  tools/

So what’s going on here? I even (despite my best judgement) set all file permissions to 777 in case it just wasn’t able to read the files for some reason. So what’s missing here?

Finally solved this myself, what a pain… hopefully this helps someone in the future

Upgrading the android platform worked for me:

cordova platform update android

is it possible to download older android-sdk?