Android Filetransfer returning null

Attempting to do an android FileTransfer, plugin is working on iOS, i can’t seem to get this to go!

ADB lgocat output:

E/PluginManager(23753): Uncaught exception from plugin
E/PluginManager(23753): java.lang.IllegalStateException: Tried to perform an IO operation on the WebCore thread. Use CordovaInterface.getThreadPool() instead.

Not sure where to look next gents, anyone happen to be an expert? (or have any luck with the cordova-plugin-file-transfer recently?)

body: null
code: null
exception: null
http_status: null
source: null
target: null

Trying a file transfer and coming back empty…
Your system information:

OS: Mac OS X Yosemite
Node Version: v0.12.0
Cordova CLI: 5.0.0
Ionic CLI Version: 1.3.22
Xcode version: Xcode 6.3.1 Build version 6D1002
ios-sim version: 3.1.1
ios-deploy version: 1.4.0

Any chance somene out there can post what they get for:

document.addEventListener("deviceready", onDeviceReady, false);
function onDeviceReady() {

I’m seeing something nonsensical!

just using the standard ngcordova upload

 $cordovaFileTransfer.upload(server, filePath, options)
      .then(function(result) {
        // Success!
      }, function(err) {
        // Error
      }, function (progress) {
        // constant progress updates

Hmm, you may have better luck asking around on stackoverflow.

Thanks for the reply, i’ll give it a shot - appears android + ngCordova + my life don’t agree with the new cordova-plugin-file-transfer and cordova-plugin-file, doesn’t appear to be completely installing (or something). i’ll throw the resolution, which may be frisbee’n my macbook out a window.

Linking threads… still finding the same error.

Continuing to pepper the internet with threads/bugs… that will work right?
Apache Cordova Jira Issue logged:

I’m still getting this error. Did you find a solution? I’m only getting this error if try to upload a photo from the gallery.
If i try to upload a photo from the camera it succeeds…

My logcat:

D/FileTransfer( 4987): upload cdvfile://localhost/content/media/external/images/media/9338 to https://XXXXXXXXXXX

D/FileTransfer( 4987): fileKey: file

D/FileTransfer( 4987): fileName: 9338

D/FileTransfer( 4987): mimeType: image/jpeg

D/FileTransfer( 4987): params: {}

D/FileTransfer( 4987): trustEveryone: false

D/FileTransfer( 4987): chunkedMode: true

D/FileTransfer( 4987): headers: {“Authorization”:“XXXXXX”}

D/FileTransfer( 4987): objectId: 2

D/FileTransfer( 4987): httpMethod: POST

D/StatusBarManagerService( 921): manageDisableList userId=0 what=0x0 pkg=WindowManager.LayoutParams

E/ViewRootImpl( 4987): sendUserActionEvent() mView == null

D/InputMethodManagerService( 921): windowGainedFocus mCurrentFocusedUserId - 0 and mSecureKeypadEnabled-false

E/PluginManager( 4987): Uncaught exception from plugin

E/PluginManager( 4987): java.lang.IllegalStateException: Tried to perform an IO operation on the WebCore thread. Use CordovaInterface.getThreadPool() instead.

E/PluginManager( 4987): at org.apache.cordova.CordovaResourceApi.assertBackgroundThread(

E/PluginManager( 4987): at org.:apache.cordova.CordovaResourceApi.mapUriToFile(

E/PluginManager( 4987): at org.apache.cordova.file.ContentFilesystem.filesystemPathForURL(

E/PluginManager( 4987): at org.apache.cordova.file.FileUtils.remapUri(

E/PluginManager( 4987): at org.apache.cordova.PluginManager.remapUri(

E/PluginManager( 4987): at org.apache.cordova.CordovaResourceApi.remapUri(

E/PluginManager( 4987): at org.apache.cordova.filetransfer.FileTransfer.upload(

E/PluginManager( 4987): at org.apache.cordova.filetransfer.FileTransfer.execute(

E/PluginManager( 4987): at org.apache.cordova.CordovaPlugin.execute(

E/PluginManager( 4987): at org.apache.cordova.PluginManager.exec(

E/PluginManager( 4987): at org.apache.cordova.CordovaBridge.jsExec(

E/PluginManager( 4987): at org.apache.cordova.engine.SystemExposedJsApi.exec(

E/PluginManager( 4987): at org.chromium.base.SystemMessageHandler.nativeDoRunLoopOnce(Native Method)

E/PluginManager( 4987): at org.chromium.base.SystemMessageHandler.handleMessage(

E/PluginManager( 4987): at android.os.Handler.dispatchMessage(

E/PluginManager( 4987): at android.os.Looper.loop(

E/PluginManager( 4987): at

Sorry, could you solve it? I have the same problem with the $ method