Android Build Dependency Error

#1

I know very little about android building. I gather that the dependencies but I’m not sure where they’re kept. I couldn’t find them in .m2.

I’m getting this when I try to build my project:

BUILD FAILED in 10s

:app:processDebugResources FAILED

26 actionable tasks: 2 executed, 24 up-to-date

/Users//Development/PurplePanda/purple-panda/platforms/android/gradlew: Command failed with exit code 1 Error output:

Intercom Android Error: Build config compile has dependency: com.google.firebase:firebase-core:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.firebase:firebase-messaging:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.firebase:firebase-analytics:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.firebase:firebase-analytics-impl:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.firebase:firebase-iid:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.firebase:firebase-common:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.android.gms:play-services-tasks:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.google.android.gms:play-services-basement:10.2.6

The Intercom SDK requires version 11.4.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.android.support:support-v4:25.2.0

The Intercom SDK requires version 27.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

Intercom Android Error: Build config compile has dependency: com.android.support:support-media-compat:25.2.0

The Intercom SDK requires version 27.x or higher of this dependency.

Check your plugins to see if any of them are bringing in this dependency

/Users//.gradle/caches/transforms-1/files-1.1/appcompat-v7-28.0.0.aar/e9851898e1bdef4d6f648a318af091c3/res/values-v28/values-v28.xml:9:5-12:13: AAPT: error: resource android:attr/dialogCornerRadius not found.