Android build broken after gradle dependencies update: Execution failed for task ':processDebugResources'. > com.android.ide.common.process.ProcessException: Failed to execute aapt


#163

what will happen if i remove the platform from the existing app?


#164

Believe not, I tried it in so many ways but the only thing that worked for me was these steps. In any cases if you need to have an plugin with appsupport it will fail your build.


#165

big thanks!! solved the issue by these steps… cheers : :clinking_glasses:


#166

And also verify if your project.properties inside platforms > android is with cordova.system.library.1=com.android.support:support-v4:23+

Just changing cordova-plugin-file-opener2 in plugin.xml didn’t work.


#167

If you are using cordova-plugin-file-opener2 try this solution: https://github.com/pwlin/cordova-plugin-file-opener2/issues/202

Just remove the old plugin and add this instead cordova plugin add https://github.com/JuanjoPP/cordova-plugin-file-opener2. Then reinstall your platforms by removing them and adding them again.

This should work without editing properties or xml files.


#168

Thank you so much, error solved!


#169

I still can’t figure out why I’m getting this problem.
I remove android and add it again. For some reason it wants to install 6.2.2 but then shows 6.2.3 in config.

I removed the file-opener2 plugin, I can build just fine. I try to add in the JuanjoPP still same error.
Add fileopen 2 plugin back in.
in the plugin.xml

In project.properties it has the same thing.

I tell it to build with android 6.3.0 No change.
I don’t know what else to try.


#170

Add this plugin it will work

cordova plugin add cordova-android-support-gradle-release


#171

It works… :grinning:
Thanks!


#172

I fixed the issue by removing multiple libraries in ./android/project.properties “com.android.support:support-v4” and putting this “com.android.support:support-v4:27+”


#173