After record, sound bugs / is stuck. (iOS)


#1

Since I’ve been answered pretty quickly last time. I’ve got another question I’d like to get solved as I don’t seem to find anyone else having the same problem. (or google just messes with me again).

I basically use this as recording.

I’ve got an event on touchstart and touchend to hold a button while recording. Works fine. Records fine, pushes fine to my server and everything.

The problem is (this only exists on debug ipa file builded by ionic) it doesn’t want to playback any sounds after I’ve recorded the first time. I’ve tried releasing it, but dosen’t make any difference. This problem does not accur when using the Ionic DevApp or Ionic View. Only on the debug IPA I’ve build through ionic.

When I’ve recorded my first record, go back to a livestream, press play and keep playing with my volume up and down buttons, I see the bar moving. After it connected to the stream, even that stops functioning. I can record many times and the app is still responding. Only I can’t modify or play any of my sounds anymore. Sound plays normally whenever I don’t record anything at all so its definitely related to the MediaPlugin somehow?

Thanks in advance!