AdmobFree doesn't start

Hello
I installed admob in my application and set it up like this in the Ionic documentation (https://ionicframework.com/docs/native/admob-free)
When the application starts the ad is not loaded.
I connected the smartphone to the PC and debugged through logcat, and detected this error:

loadUrl (javascript: cordova.fireDocumentEvent (‘admob.banner.events.LOAD_FAIL’, {“error”: 1, “reason”: “Invalid request”, “adType”: “banner”}); )

I found nothing regarding this error.
Can anyone help?
My admob setup code is this:

let bannerConfig: AdMobFreeBannerConfig = {
        isTesting: true, // Remove in production
        autoShow: true,
        id: "..."
    };
    this.admobFree.banner.config(bannerConfig);

    this.admobFree.banner.prepare().then(() => {
         this.admobFree.banner.show();
    }).catch(e => alert(e));

Thanks

Have you configured things on the AdMob side? Do you have the id in a config file? You could do something like

admob.banner.config({
id: ‘ca-app-pub-xxx/xxx’,
})

Did you have a look at https://ratson.github.io/cordova-plugin-admob-free/variable/index.html#static-variable-banner

As I showed above, I have in config the id of admob. I tried to find some specific configuration file and did not find it. This config file you refer to is where?
I’ve been researching a little bit about this, and even in tutorials put only the code I showed above.
I also tried to make ionic serve --devapp, and when opening on the smartphone appears the error “plugin not installed” but is installed.

Thank you

Update: After some searching and retrying, the error returned is already different. Now the error is this:

loadUrl (javascript: cordova.fireDocumentEvent (‘admob.banner.events.LOAD_FAIL’, {“error”: 1, “reason”: “NO FILL”, “adType”: “banner”}); )

Does anyone know what this new error might be?
PS: Thanks logant for the tip, there were some errors regarding id, so now the error is different

Thank you

Code organization problems like this are hard to diagnose piecemeal. Would it be possible for you to upload a minimal repo to someplace like GitHub that includes enough code for others to reproduce your situation?