Admob installation throws an error


#1

Technically this doesn’t count as an ngCordova issue, but:

I’ve tried installing Admob to use with ngCordova, but installation of the plugin always fails, giving me this error:

Error: Failed to fetch plugin com.google.admobsdk via registry.
Probably this is either a connection problem, or plugin spec is incorrect.
Check your connection and plugin name/version/URL.
Error: Registry returned 404 for GET on https://registry.npmjs.org/com.google.admobsdk

So of course that means that the original repo on npm has been moved or deleted, and there’s not much I can do about that, but, is there a workaround? Has the aforementioned plugin moved to a different name or location? A similar plugin that works with ngCordova?

I’m happy to update the docs if a solution is found, or just switch to a similar plugin if necessary, but it’d be good to know what’s going on, so others who run into this issue can get an answer also.


#2

facing same problem


#3

this plugin worked for me
cordova plugin add cordova-plugin-admobpro


#4

I saw the pro plugin, but figured it would be the same, as they were made by the same person and I thought would have used the same repo.

Anyway, the plugin installed correctly. Haven’t tried it in my app yet (getting the surrounding code ready), but it installed. Thanks :smile: