Admob free and build issues


#1

I am trying to use the admob-free Here. Everything works fine when I build it for my phone and it shows ads but when I put it in the store I get

plugin_not_installed

Here is my package.json Dependencies:

"dependencies": {
    "@angular/common": "4.1.3",
    "@angular/compiler": "4.1.3",
    "@angular/compiler-cli": "4.1.3",
    "@angular/core": "4.1.3",
    "@angular/forms": "4.1.3",
    "@angular/http": "4.1.3",
    "@angular/platform-browser": "4.1.3",
    "@angular/platform-browser-dynamic": "4.1.3",
    "@ionic-native/admob-free": "^4.3.2",
    "@ionic-native/core": "^3.12.1",
    "@ionic-native/splash-screen": "^3.12.1",
    "@ionic-native/status-bar": "^3.12.1",
    "@ionic/storage": "2.0.1",
    "angular-svg-round-progressbar": "^1.1.0",
    "ionic-angular": "3.6.0",
    "ionicons": "3.0.0",
    "moment": "^2.18.1",
    "rxjs": "5.4.0",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.12",
    "cordova-ios": "~4.4.0",
    "cordova-android": "~6.2.3",
    "cordova-plugin-admob-free": "~0.11.0",
    "ionic-plugin-keyboard": "~2.2.1",
    "cordova-plugin-whitelist": "1.3.1",
    "cordova-plugin-console": "1.0.5",
    "cordova-plugin-statusbar": "2.2.2",
    "cordova-plugin-device": "1.1.4",
    "cordova-plugin-splashscreen": "~4.0.1"
  },

This is where I am trying to call it:

 constructor(
    private platform: Platform, 
    private statusBar: StatusBar, 
    private splashScreen: SplashScreen, 
    private admobFree: AdMobFree) {
    platform.ready().then(() => {
      statusBar.styleDefault();
      splashScreen.hide();
    });

    const bannerConfig: AdMobFreeBannerConfig = {
      // add your config here
      // for the sake of this example we will just use the test config
      isTesting: false,
      autoShow: true,
      id: 'ca-app-pub-5035764387204735/5224848398',
      bannerAtTop: true
    };
    this.admobFree.banner.config(bannerConfig);

    this.admobFree.banner.prepare()
      .then((value) => {
        console.log('ads ready')
        this.result = value + ' ad is ready'
        // banner Ad is ready
        // if we set autoShow to false, then we will need to call the show method here
      })
      .catch(e => this.result = e + ' ad error');
  }

TLDR:
Admob-free works when I build for my phone but when I put it in the play store I get:

plugin_not_installed

Thanks!


#2

@joshuaPSmith Did you contact the people @admob? I never worked with them yet, but it’s possible they never worked with ionic hybrid apps (AdMob is part of Google now).


#3

Did you ever figure out this issue ? I am having a similar issue.