Adding plug in to existing project without repo

Just as the topic says-

Created a template ionic project - built and ran sample iOS project.

Created a template native ios plug-in project, added native code to “do it’s thing” - everything built fine.

It’s unclear how to add (within the scope of ionic) the plug-in to the stand alone app project.

The plug-in code is not in a github repo - this is purely a proof of concept - and I really can’t grant access to my company’s github repo.

I tried looking at the sample app code that has a plug-in, and for the life of me can’t see the existence of the plug-in anywhere (yet, there it is when i run it)

I’ve been developing native iOS apps since 2008, so very familiar with that side of the universe - but this is my first ionic dip. (but not first hybrid)

The existing ionic documentation falls incredibly short, and in most cases is not applicable to this seemingly common use case.

If it’s a Capacitor plugin with the Capacitor plugin project structure (package.json, folder for the iOS and/Android source code, podspec file, etc.), then you should be able to just npm install /path/to/plugin/folder and then npx cap sync.

thank you so much - i will pursue that course…

any idea what it means when the terminal spins for - over an hour - on npx cap sync with ⠸ Updating iOS native dependencies with pod install ?

looks like some CocoaPods problem.
Which CocoaPods version are you using?
What happens if you run pod install from inside ios/App/ folder?

I’ve seen CocoaPods taking some time in the first pod install call, but around 10-15 minutes, not 1 hour, when downloading a local copy of the whole CocoaPods registry, but they changed it to not do that long time ago.

Ignoring ffi-1.15.5 because its extensions are not built. Try: gem pristine ffi --version 1.15.5
Analyzing dependencies
Downloading dependencies
Generating Pods project
Integrating client project
Pod installation complete! There are 10 dependencies from the Podfile and 10 total pods installed.

[!] [Xcodeproj] Generated duplicate UUIDs:

PBXBuildFile -- Pods.xcodeproj/targets/buildConfigurationList:buildConfigurations:baseConfigurationReference:|,buildSettings:|,displayName:|,isa:|,name:|,,baseConfigurationReference:|,buildSettings:|,displayName:|,isa:|,name:|,,defaultConfigurationIsVisible:0,defaultConfigurationName:Release,displayName:ConfigurationList,isa:XCConfigurationList,,buildPhases:buildActionMask:2147483647,displayName:Headers,files:|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|,|

followed by literally thousands of lines of garbage…

try uninstalling CocoaPods and reinstall it using homebrew instead of using gem install

   CocoaPods : 1.11.3
        Ruby : ruby 2.6.10p210 (2022-04-12 revision 67958) [universal.arm64e-darwin22]
    RubyGems :
        Host : macOS 13.4.1 ((c))
       Xcode : 14.3.1 (14E300c)
         Git : git version 2.39.2 (Apple Git-143)
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib
Repositories : trunk - CDN -

okay… i will try homebrew install instead…

at this point, i was considering sacrificing some chicken nuggets to a random diety

⠋ update ios 

spinning on that now - passed update pods (after brew install cocoapods)

now on this for 30 min

The Generated duplicate UUIDs seems to appear if you have classes with the same name. Does your plugin contain classes with the same name as other plugin you have already installed or from a Capacitor class?