White Screen until Home is Pressed iOS


#1

Good afternoon,

I have a app that has been in the store for several months. But now I’ve some reports of the app getting a white screen just after the splash screen. The white screen remains until the home button is pressed. Then the app continues working well when going back to it.

This is the list of Plugins we are using:

com.phonegap.plugins.PushPlugin 2.5.0 "PushPlugin"
cordova-plugin-3dtouch 1.3.5 "3D Touch"
cordova-plugin-actionsheet 2.2.2 "ActionSheet"
cordova-plugin-app-version 0.1.8 "AppVersion"
cordova-plugin-appavailability 0.4.2 "AppAvailability"
cordova-plugin-compat 1.0.0 "Compat"
cordova-plugin-console 1.0.3 "Console"
cordova-plugin-datepicker 0.9.2 "DatePicker"
cordova-plugin-device 1.1.2 "Device"
cordova-plugin-email-composer 0.8.3 "EmailComposer"
cordova-plugin-geolocation 2.2.0 "Geolocation"
cordova-plugin-inappbrowser 1.4.0 "InAppBrowser"
cordova-sqlite-storage 1.4.8 “Cordova sqlite storage plugin”

Can you please share some light into this issue?

Thank you


#2

So, what errors do you get, it’s going to be tough to help you without an error message. Check you logs.

This is usually in issue with your app startup process, like trying to access a table that’s not created or something. Then the second time it runs the table exists and everything is fine


#3

Thanks,

The issue is that the App when I run it in Dev/simulator there is no issue. No errors. Is the App that is in production that is giving the issue.

The thing is that the App was running without problems, it was until recently that we found this issue.


#4

So does that mean you cannot reproduce it? Have you tried wiping your simulator?


#5

Ok,

The issue is still there. In the app that is in the App Store. Once you press the home button, you see the app appears, then you switch back to the app and it works without problems.

The problem is when you start the app from zero. The white screen appears just after the disolve of the splash.

No updates and changes have been made to the App in almost a year now.

Thank you very much for the attention.


#6

Were you able to resolve this? If so, what was the issue?


#7

Currently we are in testing, but it seems there is an issue with this plugin:

com.phonegap.plugins.PushPlugin

We removed it and the testing app is now working properly (without the push notifications that is : | )

I will add more details once we complete our testings.


#8

I have the same problem