Weird Android Gps permission missing problem in rc1


#1

Hi,

I tried to following the guide to update to rc1. However, we got a weird permission error. Our app used cordova gps plugin back in ionic1 and ionic2 beta. Our code has not been changed and basically similar to https://ionicframework.com/docs/v2/native/geolocation/.

The weird part is when I go to Android’s application manager, our app’s permission requirement is basically empty. I double check with ionic plugin list:

cordova-plugin-camera 2.3.0 "Camera"
cordova-plugin-compat 1.0.0 "Compat"
cordova-plugin-console 1.0.4 "Console"
cordova-plugin-device 1.1.3 "Device"
cordova-plugin-geolocation 2.4.0 "Geolocation"
cordova-plugin-splashscreen 4.0.0 "Splashscreen"
cordova-plugin-statusbar 2.2.0 “StatusBar”

and “platforms/android/AndroidManifest.xml”:





everything seems fine to us.

ionic info

Your system information:

Cordova CLI: 6.3.1
Ionic Framework Version: 2.0.0-rc.1
Ionic CLI Version: 2.1.0
Ionic App Lib Version: 2.1.0-beta.1
OS: Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS
Node Version: v6.7.0
Android version: 6.0.1

We tried to use dummy gps location instead of gps plugin to speed up the debugging process, so we don’t exactly know which ionic/cordova/lib upgrade cause the error. But we are sure the cordova gps plugin used to work in ionic2 in some point.

Anyone has any similar experience or ideas?

Thanks.


#2

nvm, just rm android and add android.