Version mismatches all over the place


#1

I am not sure what happened. But here is best I can explain. I upgraded NODE to latest for a different project in .Net Core.

Building --prod in my ionic app gets crazy errors I never saw before.
i.e. Error: Metadata version mismatch for module
…/node_modules/@ionic-native/core/decorators.d.ts, found version 4, expected 3

I prob need to update this project to newest version across the board but stopped before because of typescript errors when I tried.
I just want to know what version of Ionic I should try to update to and what version of TS I should be using. Maybe that isn’t an easy answer.

What do I need to post to get some assistance?
Thanks!!


#2

Before you do anything else, install nvm (or nvm-windows if you are running windows). They make managing situations like this much simpler.


#3

Yes, I did do that today but I just don’t know what to put my versions back to.


#4

@ionic-native/core and its @ionic-native/xxx friends all need to be on the same major version: 4.x for Ionic framework 3 (ionic-angular) and 5.x-beta for Ionic 4 (@ionic/angular).