[v4] ion-chip not rendering ion-icon native on iOS?

HI,
Is anyone else seeing an issue where an ion-chip (ionic v4 beta 13) won’t render an icon? It’s fine using ionic serve and the browser (emulating ios or android) but using the iOS simulator or device no icon is shown. Think it could be a margin issue:

<ion-chip>
  <ion-label>
    Example
  </ion-label>

  <ion-chip-button>
    <ion-icon name="close"></ion-icon>
  </ion-chip-button>
</ion-chip>

ion-chip

give me 15 minutes, I’ve to test my app on iOS will test that in the same time

1 Like

yep I don’t see any icons on my iPhone neither

<ion-chip>
<ion-label>Button Chip</ion-label>
<ion-chip-button>
<ion-icon name="close-circle"></ion-icon>
</ion-chip-button>
</ion-chip>
1 Like

@reedrichards thanks for checking! I’m pretty sure it’s the right syntax (I don’t think you can specify a slot etc) so I guess it’s a bug.

Maybe you should check if there is an issue open or open one?

Thanks yes I did check, so when there wasn’t one I assumed it might just be our app that was affected. To be honest though, the issue list against Ionic is currently a bit out of control and they probably need to start again or do a massive close-fest. A lot of them are support questions/noise. The two other issues I raised recently haven’t been commented on.

Difficult to keep a public open source tracker up-to-date when many users are using your project. Anyhow I guess if you see no improvements in the follow-up version I guess at some point it would still be good to report it