Using plugins not supported

Hi,
Would like to check what would be the expected behaviour should we use plugins which are not supported by the platform? e.g. switchToLocationSettings() is supported in Android but not IOS. Will the ionic framework compile this part of the code for IOS or just skip it totally?
Thank you