Upgrading broke ng-repeat


#1

So I was merrily working along, app running great, lots of progress, when I got a message that ionic 1.1.2 (I think it was) is available and I might want to npm install it. So I did, and stuff stopped working. So I updated cordova, and that didn’t help. So I tried upgrading/downgrading/sidegrading angular, but nothing helped. The symptom is that the app comes up (ionic serve) in my Chrome browser, but the ng-repeats don’t populate, modals don’t pop-up, and I don’t know what else. No compile or console errors at all.

My other ionic projects are broken too, so something has changed globally on my machine.

Here is my current set of versions, I went back to ionic#1.0.0-beta.13 that worked before:

IxAxessYo#0.0.7 /Users/lannie/worksp/gui/IxAxessYo
├─┬ angular-mocks#1.2.27 (1.2.28-build.573+sha.a1e7eb6 available, latest is 1.3.7-build.3695+sha.aac3c4a)
│ └── angular#1.2.27 (latest is 1.3.7-build.3695+sha.aac3c4a)
├─┬ angular-scenario#1.2.27 (1.2.28-build.573+sha.a1e7eb6 available, latest is 1.3.7-build.3695+sha.aac3c4a)
│ └── angular#1.2.27
├─┬ ionic#1.0.0-beta.13 (latest is 1.0.0-beta.5b)
│ ├── angular#1.2.27 (1.2.28-build.573+sha.a1e7eb6 available, latest is 1.3.7-build.3695+sha.aac3c4a)
│ ├─┬ angular-animate#1.2.27 (1.2.28-build.573+sha.a1e7eb6 available, latest is 1.3.7-build.3695+sha.aac3c4a)
│ │ └── angular#1.2.27
│ ├─┬ angular-sanitize#1.2.27 (1.2.28-build.573+sha.a1e7eb6 available, latest is 1.3.7-build.3695+sha.aac3c4a)
│ │ └── angular#1.2.27
│ ├─┬ angular-ui-router#0.2.10 (latest is 0.2.13)
│ │ └── angular#1.2.27 (1.3.7-build.3695+sha.aac3c4a available)
│ └── collide#1.0.0-beta.3
└─┬ restangular#1.4.0 extraneous
  ├── angular#1.2.27 (1.3.7-build.3695+sha.aac3c4a available)
  └── lodash#2.4.1

I am on a Mac OS X 10.9.5 and I started out with yeoman / generator-ionic. About this same time, I think just before I started upgrading, I did this project’s first build for android (and the android .apk works fine), so that may or may not be part of the problem. Any ideas for me? Or even how to clean out my system globally and re-install from scratch?


#2

More info from me … I found /usr/local/lib/node_modules/ionic and I see that package.json says ionic is version 1.2.12. I’m confused … is this ionic 1.2.12 the ionic cli, while the actual ionic code that goes in my app is ionic#1.0.0-beta.13 ?

I created a new project using “yo ionic” and when I “grunt serve” I’m getting this error:

events.js:72
throw er; // Unhandled ‘error’ event

I see another thread about this error from some time back, but the resolution seemed to be to update ionic, so that doesn’t seem to help me.


#3

So ionic -v will return the CLI version number, which in this case is 1.2.12.

Beta 13 refers to the version of the actual ionic code, ionic.js and ionic.css

Now are you using the ionic cli for your project or the yeoman generator?
Just a heads up, the yeoman generator is a community project, so we don’t work on that.


#4

Magic! The system healed itself, now it works! So this issue is closed, at least for now, I hope forever. I don’t think I did anything. I spent the morning installing an identical build environment in an Ubuntu VM, but that shouldn’t have affected OS X. Oh well, I’ll take it anyway.

But, to answer your question, I mostly use “sudo grunt serve” to use their auto-reloading server. It looks like it is “ionic serve” under the hood, as the grunt config is “grunt.config(‘concurrent.ionic.tasks’, [‘ionic:serve’, ‘watch’]);”. But I try “ionic serve” alone when I’m having problems like yesterday. Generally I’ve found the yeoman generator-angular build environment to be very helpful and trouble-free.