Upgrade to IonicPro - Linking an existing ionic project doesn't work

Steps…

  1. npm install -g ionic@latest
  2. ionic link --pro-id
  3. Receive Error - “You cannot run this command unless you are in an Ionic Project folder”
  4. ?

Cordova CLI: 7.0.0
Ionic Framework Version: 3.0.1
Ionic CLI Version: 2.2.2
Ionic App Lib Version: 2.2.1
Ionic App Scripts Version: 1.3.0
ios-deploy version: 1.9.1
ios-sim version: 5.0.13
OS: macOS Sierra
Node Version: v7.10.0
Xcode version: Xcode 8.3.1 Build version 8E1000a

Ionic CLI 2.2.2 is not even close to latest. Something is wrong here

The same thing is happening with the following environment…

@ionic/cli-utils  : 1.9.2
ionic (Ionic CLI) : 3.9.2

global packages:

Cordova CLI : 7.0.1 

local packages:

@ionic/app-scripts : 1.3.0
Cordova Platforms  : ios 4.4.0
Ionic Framework    : ionic-angular 3.0.1

System:

ios-deploy : 1.9.1 
ios-sim    : 5.0.13 
Node       : v7.10.0
npm        : 4.2.0 
OS         : macOS Sierra
Xcode      : Xcode 8.3.1 Build version 8E1000a
1 Like

What command exactly are you running and what is the exact output? (Please copy both in one part - add --verbose to the command for more output)

It linked eventually. But I think I’m just going to opt out of IonicPro. My desire was to use it for push notifications and it doesn’t appear to have that functionality. I ended up using FCM instead. Thanks for your help.

1 Like