Update Angular-Ui-Router in ionic 1

My project is pretty old with ionic 1 and angular-ui-router 0.2.13.

Now I’m encountering a bug from angular-ui-router and found that it will be fix if I upgrade the angular-ui-router to version 1 and above.

Tried bower/npm install angular-ui-router and get the following errors.

“ECONFLICT Unable to find suitable version for angular-ui-router”

Also tried updating the version number from bower.json inside angular-ui-router folder. Not working.

Can someone help let me know how can I upgrade this angular-ui-router please?

Thanks in advance.