Unable to get real-time logs for cordova app running on iphone simulator

Rather strangely I’m finding it difficult to get real-time logs for my cordova app in the iphone simulator. Is this a known issue?

I’ve tried opening the emulator’s system log but it doesn’t show my app’s logs even when I search for the bundle ID. And I’ve tried adding this environment variable without any luck

I’ve also tried looking directly in xcode but there’s no “open console” button when I select the simulator device in the “devices and simulators” screen. You can see in this screenshot, this is for a simulator that is currently running


And I’ve tried using this command xcrun simctl spawn booted log stream --debug --predicate 'subsystem == "com.example.yourapp"' from this suggestion but it only gives Error from getpwuid_r: 0 (Undefined error: 0) followed by a line with a blank cursor, as if no log entries are being sent. I can’t find any posts for that error that could be related to my situation.

I’m using xcode 13 on an M1 mac. Any ideas that could help?