Unable to fetch platform android

I am getting the same error when I try to add the ios platform. I have upgraded everything I can think of. npm, cordova, ionic…

npm http GET https://registry.npmjs.org/cordova-android/-/cordova-android-3.6.1.tgz
npm http 200 https://registry.npmjs.org/cordova-android/-/cordova-android-3.6.1.tgz
Unable to fetch platform android: Error: shasum check failed for /var/folders/gh/qfcr2gfx02s9jgrwsyfvlvch0000gn/T/npm-28546-3fuLX4RW/1410477273910-0.5852393007371575/tmp.tgz
Expected: b9138a0743c4f424ee62721c22dac84e8d1ca087
Actual: a5c74dea5a0225566e4a54185d8639a7f7f6ac3e

Suggestions greatly appreciated!

I am receiving the same message as well from a Windows box as well. I am new to Ionic…so, help! Any suggestions greatly appreciated!

Same … I started getting this a few hours ago after updating ionic and cordova

I just upgraded also is there any way to go back

I’m getting the same problem with ios as well

npm http GET https://registry.npmjs.org/cordova-ios/-/cordova-ios-3.6.1.tgz
npm http 200 https://registry.npmjs.org/cordova-ios/-/cordova-ios-3.6.1.tgz
Unable to fetch platform ios: Error: shasum check failed for /var/folders/9h/51gq5y092dj65kht929ykfx40000gn/T/npm-411-2-tYC6jt/1410479886531-0.253101525362581/tmp.tgz
Expected: ae3d0a39e25f21c897812029c3fbc7f816d592a7
Actual: ffed0885409aed998b6d351fcae46518ad279a02

Yea … it seems like they haven’t updated the checksum information in the latest release

This is a Cordova problem, there is a ticket on their jira.

I love the last entry from Cordova’s JIRA ticket.

“This has got me thinking that between this snafu, and the 3.6.0 rc snafu, we need to amend the release process to always publish to a test registry first and validate there before publishing to registry.npmjs.org.”

What do they do over there? Faith-based development and deployment?

They probably do what I do.

After speding some more time in the Googlesphere, here is what I found as workarounds…

I was able to repair my Ubuntu 14 terminal.
In my terminal setup a file, .bash_profile was some how created.
Once I renamed that file and opened new terminal all is working now.

Here’s the workaround that worked for me:

cordova platform --usegit add android

Thank you urbgimtam this also works for me. you saved my day :slight_smile: