Unable to build after first iOS build


#1

I was able to get a build of ios finally, and get into xCode, and get onto my iPad, it was rather exciting. Then I realized I needed to make a change, so I open up my code (the ionic code, not the xCode project), change the URL of a data source that had a typo in it. Head back to the terminal window to build it out again for xCode, type in…

ionic cordova build ios
Hit enter, and boom, errors now. Only it isn’t anything I have seen before this time it is saying…

cp: copyFileSync: could not write to dest file (code=ENOENT):/Volumes/SharedFolders/shared_app/platforms/ios/._2freedom/config.xml

I have no idea why it isn’t there, where it went, or what it even does. It built out great the first time, but now every time I try to build ios it says the same error. Is there something you have to do special after you build for ios and launch in Xcode? I closed out the Xcode project, but still no go. Thank you in advance for any advice you can give with this. The whole building for iOS has been a major headache, I really wish it were all as easy as Android, lol.


#2

try
ionic platform rm ios
then
ionic platform add ios
and then
ionic build ios
if it doesn’t work try to build with sudo :
sudo ionic build ios
if the build succeeds with sudo then tell us here and I’ll give you the solution for that !


#3

No, do not use sudo. Note that the error is not EPERM, but rather ENOENT. The file or some directory along the way does not exist.


#4

Is this related to your app’s name in any way?


#5

Yes it is, the app is called 2freedom. The strange thing is, it compiled the first time just fine, I ran it in X code and had it on my iPad, but when I tried to build it a second time I started getting that error. I can confirm there is no directory called “._2freedom” but I never removed it, and don’t even know what it would contain.


#6

Ok, . would make it a hidden folder. Maybe something temporary…

  1. Try running the same command with --verbose added at the end.
  2. Try running the command without ionic in the front.