Trouble updating v1.7.6 to newest npm version

After performing sudo npm i -g ionic to update my version I get:

npm WARN install:wordwrap ENOENT: no such file or directory, rename '/usr/local/lib/node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/wordwrap' -> '/usr/local/lib/node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/wordwrap'
lazy-cache@0.2.4 node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/center-align/node_modules/lazy-cache -> node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/center-align/node_modules/lazy-cache
wordwrap@0.0.2 node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/wordwrap -> node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/wordwrap
- /usr/local/lib/node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui
- /usr/local/lib/node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/right-align node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/right-align
- /usr/local/lib/node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/right-align/node_modules/align-text node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/right-align/node_modules/align-text
- /usr/local/lib/node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/right-align/node_modules/align-text/node_modules/kind-of node_modules/ionic/node_modules/ionic-app-lib/node_modules/ionic-cordova-lib/node_modules/cordova-js/node_modules/uglify-js/node_modules/yargs/node_modules/cliui/node_modules/right-align/node_modules/align-text/node_modules/kind-of
/usr/local/lib
ā””ā”€ā”€ (empty)

npm ERR! code 1

Iā€™m currently running Ubuntu 15.04, Node version 5.0.0, npm version 3.3.6

Anyone running into a problem like this?

For future reference: i encountered this problem with Win10 & Node 4 branch & NPM3. Reverting to NPM2.x solved it for me.

after the downgrade you can npm install lazy-cache --save

edit: cheered a little to early. Got the same issue. Even when checking out a new ionic2 starter

Cordova CLI: 5.4.1
Gulp version: CLI version 3.9.0
Gulp local:
Ionic Version: 2.0.0-alpha.49
Ionic CLI Version: 2.0.0-beta.12
Ionic App Lib Version: 2.0.0-beta.6
OS:
Node Version: v4.2.4

NPM 2.14.12

trying w/ npm3 now, after a fresh install of nodejs