Tried calling FirebaseX.subscribe, but the FirebaseX plugin is not installed

I recently ran in to this problem out of no where. Every thing was working perfectly fine before, but recently I am not able to subscribe to a topic. I cant see the topics name on the cloud messaging portal.

The weird part is that I already have the plugin installed.
I ran the following commands.

ionic cordova plugin add cordova-plugin-firebasex
npm install @ionic-native/firebase-x

Here is a part of my cordova plugin list

ordova-plugin-firebasex 9.0.2-cli "Google Firebase Plugin"
cordova-plugin-googlemaps 2.7.0-20200330-2338 "cordova-plugin-googlemaps"
cordova-plugin-ionic-keyboard 2.1.3 "cordova-plugin-ionic-keyboard"
cordova-plugin-ionic-webview 4.1.1 "cordova-plugin-ionic-webview"
cordova-plugin-market 1.2.0 "Market"
cordova-plugin-nativestorage 2.3.2 "NativeStorage"
cordova-plugin-screen-orientation 3.0.2 "Screen Orientation"
cordova-plugin-splashscreen 5.0.3 "Splashscreen"
cordova-plugin-statusbar 2.4.3 "StatusBar"
cordova-plugin-whitelist 1.3.4 "Whitelist"
cordova-plugin-x-socialsharing 5.4.7 "SocialSharing"
cordova-promise-polyfill 0.0.2 "cordova-promise-polyfill"

Any one familiar with this situation?

My Advise when running into “dump” errors:

  • Remove platforms Folder
  • Remove plugins Folder
  • Remove www Folder
  • Remove packge-lock.json
  • Run ionic cordova platform add android (or ios)
  • Build again