Suddenly gets error when compiling for Release Only Android!


#1

Hi!
I suddenly gets failure when I try to compile for Relase. Havn’t done anything special with the code.

What is happening???

Here is my error:

:generateReleaseSources
:compileReleaseJavaWithJavacNote: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /home/package/workspace/apps-0984178c-29/cordova/platforms/android/src/com/synconset/MultiImageChooserActivity.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

:compileReleaseNdk UP-TO-DATE
:compileReleaseSources
:lintVitalRelease/home/package/workspace/apps-0984178c-29/cordova/platforms/android/res/values/multiimagechooser_strings_en.xml:7: Error: “discard” is not translated in “de” (German), “es” (Spanish), “fr” (French), “hu” (Hungarian), “ja” (Japanese), “ko” (Korean) [MissingTranslation]
Cancel
~~~~~~~~~~~~~~
/home/package/workspace/apps-0984178c-29/cordova/platforms/android/res/values/multiimagechooser_strings_en.xml:8: Error: “done” is not translated in “de” (German), “es” (Spanish), “fr” (French), “hu” (Hungarian), “ja” (Japanese), “ko” (Korean) [MissingTranslation]
OK
~~~~~~~~~~~
/home/package/workspace/apps-0984178c-29/cordova/platforms/android/res/values/strings.xml:3: Error: “app_name” is not translated in “de” (German), “es” (Spanish), “fr” (French), “hu” (Hungarian), “ja” (Japanese), “ko” (Korean) [MissingTranslation]
Allsang pa Grensen
~~~~~~~~~~~~~~~
/home/package/workspace/apps-0984178c-29/cordova/platforms/android/res/values/strings.xml:4: Error: “launcher_name” is not translated in “de” (German), “es” (Spanish), “fr” (French), “hu” (Hungarian), “ja” (Japanese), “ko” (Korean) [MissingTranslation]
@string/app_name
~~~~~~~~~~~~~~~~~~~~
/home/package/workspace/apps-0984178c-29/cordova/platforms/android/res/values/strings.xml:5: Error: “activity_name” is not translated in “de” (German), “es” (Spanish), “fr” (French), “hu” (Hungarian), “ja” (Japanese), “ko” (Korean) [MissingTranslation]
@string/launcher_name
~~~~~~~~~~~~~~~~~~~~

Explanation for issues of type “MissingTranslation”:
If an application has more than one locale, then all the strings declared
in one language should also be translated in all other languages.

If the string should not be translated, you can add the attribute
translatable=“false” on the element, or you can define all your
non-translatable strings in a resource file called donottranslate.xml. Or,
you can ignore the issue with a tools:ignore="MissingTranslation"
attribute.

By default this detector allows regions of a language to just provide a
subset of the strings and fall back to the standard language strings. You
can require all regions to provide a full translation by setting the
environment variable ANDROID_LINT_COMPLETE_REGIONS.

You can tell lint (and other tools) which language is the default language
in your res/values/ folder by specifying tools:locale=“languageCode” for
the root element in your resource file. (The tools prefix
refers to the namespace declaration http://schemas.android.com/tools.)

5 errors, 0 warnings

:transformClassesWithDexForRelease FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:transformClassesWithDexForRelease’.

com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process ‘command ‘/usr/lib/jvm/java-7-openjdk-amd64/bin/java’’ finished with non-zero exit value 1

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 1 mins 14.849 secs


#2

Hi, I just had the same issue. I solved it by adding

lintOptions {
checkReleaseBuilds false
abortOnError false
}

to the android {} section in /platforms/android/build.gradle


#3

Use this code in /platforms/android/build.gradle

lintOptions {
       abortOnError false;
       disable 'MissingTranslation';
    }