Strange behavior after upgrading to Cordova 6 + Ionic latest 1.2.x


#1

Hi guys,

I have one app on production right now built with ionic 1.1.1 and cordova 5 may be + crosswalk it was running just fine and I was using native scrolling.

the scroll was smooth.

Also I am using infinite scroll, and in the app it is always showing the spinner rotating until the new data arrives. Also, if I used the spinner any where it will keep rotating until the operation finished.

BUT …

I upgraded to Cordova 6 and latest ionic 1.2.x + crosswalk and a lot of strange behaviors appeared!

Native scrolling is slower! + a lot of strange rendering issues happens when I am scrolling too fast like some of my cards are not showing completely then suddenly it appears + the cards are partially rendered and then the missing parts appear + the card appear blurry then it become clear + spinner always freeze not rotating at all in any place and after a while the data is returned which defeats the purpose of the spinner!.. mix of all those strange behavior

I upgraded because I wanted to hook to menubutton event which wasn’t available until upgrading with a workaround to make it work!

Any clue?

Thanks.


#2

Any hint guys about those issues?


#3

Yes Please, can we have a solution to this soon
Thanks


#4

The same here, any solutions to this please?
Thanks


#5

Still no replies about those issues?


#6

Did you try to downgrade to cordova 5.1.1
I had some issues with cordova 6 so I went back to 5.1 and every thing worked fine


#7

Can you tell what were the issues?

Actually I wanted to use the menubutton event which was not working until I upgraded! So, the upgrade was important to me?


#8

sry … i don’t know where the issues , but i can’t get the (menubutton events) , would you explain more ?


#9

The hardware settings button wasn’t working until I upgrade to latest cordova.

I meant what were the issues you were facing, so you have downgraded to solve them?


#10

Did you ever solve this? I am also having spinner problems (only on device, web is fine), and I’m using Cordova 5.4.1. I don’t mind downgrading to solve the problem, should I try Cordova 5.1.1?

Marc


#11

Not yet unfortunately!