[SOLVED] Ionic lab output is nulled and command line doest working

hello there i just getting started with mobile apps and use ionic lab, but when am trying to see the output both in the browser and ioniclab, the output is show nothing (see the picture below)

And the command line error:

Muhammad Ihsan@ZEUS MINGW64 /c/xampp/htdocs/mapp-estetika (develop)
$ ionic serve
The port 35729 was taken on the host localhost - using port 35730 instead
Gulp startup tasks: 0=sass, 1=watch
Running live reload server: http://localhost:35730
Watching: 0=www//*, 1=!www/lib//*
Running dev server: http://localhost:8100
Ionic server commands, enter:
restart or r to restart the client app from the root
goto or g and a url to have the app navigate to the given url
consolelogs or c to enable/disable console log output
serverlogs or s to enable/disable server log output
quit or q to shutdown the server and exit

ionic $ An uncaught exception occurred and has been reported to Ionic

listen EADDRINUSE (CLI v1.7.7)

Your system information:

Cordova CLI: 5.3.3
Gulp version: CLI version 3.9.0
Gulp local: Local version 3.9.0
Ionic CLI Version: 1.7.7
Ionic App Lib Version: 0.6.3
Node Version: v4.1.2

Muhammad Ihsan@ZEUS MINGW64 /c/xampp/htdocs/mapp-estetika (develop)
$ C:\xampp\htdocs\mapp-estetika\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:22
throw new Error(’libsass bindings not found. Try reinstalling node-sass?’);

Error: libsass bindings not found. Try reinstalling node-sass?
at getBinding (C:\xampp\htdocs\mapp-estetika\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:22:11)
at Object. (C:\xampp\htdocs\mapp-estetika\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:188:23)
at Module._compile (module.js:434:26)
at Object.Module._extensions…js (module.js:452:10)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at Object. (C:\xampp\htdocs\mapp-estetika\node_modules\gulp-sass\index.js:3:17)
at Module._co

i’ve find a lot of way to solved this problem like npm rebuild node-sass but nothing change.
Please help me i need your advice, and thankyou before.

1 Like

What worked for me was this answer from flavordaaave

I fixed it by changing the version for “gulp-sass” in the package.json to ^2.0.4.

Then run
$ npm install gulp-sass
This should now update your local gulp-sass to a newer version that is supporting node 4.x


Thank you! That worked for me :smile:

thank youuu! Solved! :smiley: