[solved] Android build broken in Cordova 6.4 (cordova-android 6.0.0 not working with Crosswalk)


#1

This took me a long time to track down, wondering if anyone knows about this. After updating to Cordova 6.4 from 6.3.1, my Android build is broken. It first tells me I must accept the license agreement for sdk 24, which I never previously did. So, okay, I go accept the license agreement.

Now I can create Android, but when I build the res folder in the Android platform folder has default Cordova splash screens and icons. Stranger still, my splash screens and icons are in a new res folder that was created in the root of the project.

Even if I copy and paste that res folder into the proper place, my app crashes on launch. I’m currently reverting my Cordova version to 6.3.1 again in hopes that everything goes back to working.

Is this a known issue? Any ideas?

Thanks,
Rob


#2

I had that problem in 6.4.0 Opened the sdk manager and made sure I had the 24 SDK then I downloaded 23 SDK and accepted the license agreements there and ran ‘ionic run android’ and it all worked.


#3

Oh interesting, and you didn’t have the same issues with the “res” folder in the wrong place or app crashing? Because I do have 23 and 24 downloaded and licenses accepted, yet I still have this issue. Maybe something to do with the version of the splashscreen plugin I have? I really can’t think of a reason as to why this would happen.


#4

I did not - just the license agreement. The splash screen plugin could be the thing as well though. Have you tried reinstalling it and checking if there’s a newer version of it - specifically made for 6.4.0 if needed?


#5

I’ve found the true issue, while yes Cordova 6.4 did make me accept additional license agreements, it did not cause the crashes. What caused the crashes was using cordova-android 6.0.0. Reverting back to 5.2.2 fixed the issue for me ionic platform rm android then ionic platform add android@5.2.2. I also updated platforms.json to 5.2.2 and altered my .gitignore to allow the platforms folder (but not the ios and android sub folders) to store that permanently.

Seems like the true culprit here was Crosswalk, it’s not too happy about cordova-android 6.0.0 apparently.


#6

Same problem, fixed with your solution thx @rlouie!


#7

Please find below solve the issue for me


#8

I had to do this as well. The getting started docs don’t show enough info for Android.